PHP с использованием другой библиотеки libxml2 версии, чем установлена в /usr/lib в/

Я попытался установить Медиавики, который сказал мне, чтобы обновить свои библиотеки libxml2, по крайней мере, версия 2.7.3. Так что я проверил это и нашел в/usr/lib в/библиотеке libxml2.так.2.7.6 должны быть установлены. белый xml2-config --указывает версию также возвращает 2.7.6. Но при чтении выходы функцию phpinfo(); он говорит мне в libxml скомпилированная версия является 2.6.32.

Как я могу сказать PHP, чтобы использовать правильные библиотеки libxml2, избегая перекомпиляции чего-либо от руки, как я люблю использовать пакет обновлений Ubuntu в будущем.

Я в настоящее время работает Ubuntu 10.04.3 (осознанные) LTS и после установки PHP5 и libapache-Mod-в рнр5 пакеты от основных источников (на PHP 5.3.5-0.dotdeb.0).

+503
Patrick Harrington 13 окт. 2011 г., 5:43:07
23 ответов

[Править]по-видимому, места еще есть, но они похоронили его довольно хорошо!

Так как я не хочу, чтобы расслабиться на рабочем столе, чтобы открыть меню Мои места (я использую мой внешний акций довольно часто), я добавила домашней иконы сохраненные как описано в Что пользовательских установок и единства Quicklists доступны? чтобы создать, но добавил записей в мой обычный пульт дистанционного акций, например, так:

[Ярлык Группы Паспорт]
Имя=Отличается Своим Внешним
В exec=Наутилус СМБ://readyshare/отличается/
+933
stanete 03 февр. '09 в 4:24

Ubuntu и Linux в целом не имеет лучший послужной список по поводу обновлений, если использовать LTS-версиями. Поэтому лучшим решением может быть, чтобы сохранить ваши данные извне, а затем делаешь новую установку 12.04.

+889
nikola7240 30 июн. 2010 г., 22:46:55

Вы используете Ubuntu на Mac? Если да, то вы можете изменить яркость экрана, используя следующую команду:

Эхо 4 | судо тройник /системы/класса/подсветка/acpi_video0/яркость

Диапазон значений: от 1 до 10 [1 Низкий, 10 самых]

Также вы можете настроить яркость при пуске. Добавьте строку в файл/etc/файл RC.местные до выхода 0

+842
gs21 19 июн. 2018 г., 22:36:14

Будет единство интерфейса быть только по умолчанию в 11.04 или пока оболочка гном? Или же единство будет продолжать развиваться после того, как оболочка гном готов.

Просто: будет 11.04 единичный релиз в интерфейс Unity по умолчанию.

+815
Brij Vaid 21 мар. 2018 г., 5:57:27

Ну, установить libfaac первый. Похоже, произошла ошибка делаем так. Убедитесь, что apt-получить установку libfaac-Дэв работ.

Правильная инструкция по установке ffmpeg и x264 на здесь.

судо apt-получить обновление
суда apt-получить -г установка сборки-необходимые checkinstall libfaac-Дэва ГИТ libgpac-Дев \
 libjack-jackd2-libmp3lame Дэв-Дэв libopencore-amrnb-Дэв libopencore-amrwb-Дев \
 libsdl1.2-Дев libtheora-Дев libva-dev и libvdpau-dev и libvorbis были-Дев libx11-Дев \
 libxfixes-Дэв texi2html zlib1g-dev и ясм 

Затем, для x264:

компакт-диск
в Git клон git://git-репозитории.у VideoLAN.орг/у x264
компакт-диск для x264
./настройки --включить-статический
сделать
команду sudo checkinstall --имя_пакета=у x264 --pkgversion="3:$(./version.sh | \
 на awk -F' и[" ]' '/точки/{печати $4"+ГИТ"$5}')" --резервное копирование=нет --deldoc=да \
 --fstrans=нет --по умолчанию

И для ffmpeg:

компакт-диск
клон git --глубина 1 ГИТ://источник.через FFmpeg.орг/видео
компакт-диск пакет ffmpeg
./настроить опцией --enable-GPL с опцией --enable-libfaac опцией --enable-libmp3lame --включить-libopencore-amrnb \
 --включить-libopencore-amrwb --включить-libtheora опцией --enable-libvorbis были \
 --включить-поддержкой libx264 опцией --enable-nonfree в --Включить-версия_3 опцией --enable-x11grab
сделать
команду sudo checkinstall --имя_пакета=через FFmpeg --pkgversion="5:$(Дата +%г%м%д%ч%м)-мерзавец" - резервное копирование нет=\
 --deldoc=да --fstrans=нет --по умолчанию
хэш у x264, ffmpeg с ffplay ffprobe

Вот это — фильтры должны быть автоматически включены.

+799
Ricardo PenaMcKnight 16 мая 2012 г., 16:59:26

Я предполагаю, что данные в Ubuntu пишет на USB-накопитель, потому что он сохраняет конфиги, которые мы выбираем. Например, если я установить Ubuntu на компьютер, выбрав "португальский язык" как язык, в следующий раз, когда я запустить Убунту с Live USB будет использовать "португальский" как язык по умолчанию.

Но я не знаю, где он записывает данные.

+777
NuMarAki 4 нояб. 2014 г., 7:41:57

Не смогли установить Ubuntu с USB или CD. У меня Ubuntu 12.04 установлен, но мне придется переформатировать мой ноутбук. Ни диска, ни с USB ботинки. Я хочу что-то подобное может помочь мне ботинок.

+753
shyman877 6 сент. 2017 г., 17:10:21

Если вы не классифицировать систему как ценный, я бы сказал, что по умолчанию не достаточно. Я бы порекомендовал прочитать ориентиры СНГ в Debian, Apache и выполнения рекомендаций закаливание. Более конкретно из входов поле "корень" разрешено с SSH-сервер, который по-настоящему глуп. Прилагаю ссылку на сайт, где вы можете их скачать.

http://benchmarks.cisecurity.org/en-us/?route=downloads.benchmarks

+656
Testo GX 19 дек. 2016 г., 18:37:37

Я недавно установил 12.04, и начали возиться с линзами. Я установил две области для музыки объектива: Spotify и заготовок.

Мне кажется, что текущая область порядок отображения в алфавитном порядке названий области? Когда делаешь поиск, бесплатно хиты всегда представлен выше в Spotify.

Есть ли возможность сортировки/порядок/приоритет презентации области в некотором роде?

+645
Dennis Michels 22 дек. 2013 г., 17:02:52

Мне часто приходится редактировать .файлы KML (Google Планета Земля) файлов, этих может быть очень трудно иметь дело с в обычный редактор, и мне нужно немного больше, чем подсветка синтаксиса, мне нужно иметь возможность проверить .кмл перед открытием в GE.

кто-то рекомендовал для jedit мне за это, но я нахожу это немного вяло и трудно настроить, чтобы нормально работать .кмл, какие рекомендации? Плагин для редактора gedit возможно? Может, что-то под Emacs, да я использую Emacs тоже.

+624
Prashant Gonga 20 нояб. 2018 г., 18:57:04

у меня есть сервер Ubuntu (13.04) с 3 сетевыми картами. Это моя таблица маршрутизации:

Пунктом Genmask Шлюз Флаги Метрики Использовать Реф Недвижимость
по умолчанию Водафон.статио 0.0.0.0 УГ 0 0 0 p1p1
192.168.8.0 * 255.255.255.0 u 0 не 0 0 p2p2
192.168.17.0 * 255.255.255.0 u 0 не 0 0 p2p1

Сервер на интерет и видит 2 подсети. Мой компьютер находится в подсети 17.ХХХ, я могу пинговать все компьютеры в подсети 8.ХХХ но я не могу выйти в интернет.

Как я могу настроить таблицу маршрутизации, чтобы перенаправить мой запрос в интернете?

+603
Cintia Shinoda 30 дек. 2012 г., 1:12:51

Зайти в Системные настройкиисточниками программного обеспечениядругое программное обеспечение и unchek все. Может быть, это поможет.

+551
yerlikayaoglu 8 мар. 2018 г., 11:49:24

Насколько я знаю, это не построено в UpdateManager в любом месте.

Вы можете найти это , чтобы быть связанным, хотя не идентичны.

+505
Sabrina Schaefer 26 авг. 2013 г., 1:10:48

Возможные Дубликаты:
Что DLNA-сервер выбрать?

как название говорит им поиск медиасервер для Ubuntu 12.04. Я уже пробовал Mediatomb, Serviio, Миро (медиа-менеджмент), певунья (менеджмент СМИ). Но дело в том, что мне нужен медиасервер, который способен обмениваться медиа через DLNA и который является производительным, так необязательно с внешним сервером баз данных. Проблема в том, что у меня очень большая коллекция СМИ, и средства управления СМИ, как певчая птица и Миро не справляется с такой большой контент.

Вы знаете какие-то хорошие серверные решения для управления мультимедиа и обмена?

+480
Dragosmsm 7 мар. 2015 г., 21:11:29

Даунгрейд с ППА

:~$ АПТ-кэш показать ППА-продувки

Описание: отключает ППА и возвращается в официальные пакеты

Эта программа отключает ППА из ваших источников программного обеспечения и возвращается вашей системы обратно в официальные пакеты Ubuntu. Вы можете использовать это, чтобы вернуть систему к нормальному после тестирования новой версии от ППА.

Домашняя страница: https://launchpad.net/ppa-purge

Он доступен из осознанного-бэкпортов: http://packages.ubuntu.com/search?keywords=ppa-purge&searchon=names&suite=all&section=all

Подробнее:

+461
David Mat 18 мая 2018 г., 7:03:33

Не сильно поможет я знаю, но у меня было так много проблем с ATI и Ubuntu, и Mint на то пошло.

Мне пришлось переустановить ОС несколько раз опростоволосившись на водителей, подкачка, и т. д.

Я использовал драйверы ATI, которые установлены с Ubuntu, драйверы, предоставленные дополнительные драйверы, последние драйверы ATI на сайте.

В конце концов, я установил видеокарту NVIDIA, и это сработало мгновенно без проблем.

Опять же, к сожалению это не поможет, но если у вас есть карты Nvidia валятся, я бы посоветовал использовать его вместо. Другие, Без сомнения, лучший совет в отношении вашей карты и драйверы я уверен.

+445
BitcoinZZZ 13 авг. 2012 г., 15:42:45

Я нашел баг в единстве описано здесь: https://bugs.launchpad.net/ubuntu/источник/Федеральное/+ошибка/751909 Я буду держать глаз на билет и посмотреть, если он закреплен. Если они не исправить это до октября, я буду обновление до Онейроидного

+407
Drew Noakes 26 окт. 2015 г., 8:51:12

Вы пробовали бежать 10.10 через Live CD, чтобы проверить производительность?

Я нашел этот ОМГ Убунту пост о фиксации драйвер для NVIDIA в 10.10, что может помочь, если по умолчанию это дает вам проблемы, кроме одной на Убунту форумах, но некоторые замечания о ОМГ могут быть полезны.

+355
Melissa 16 апр. 2011 г., 21:22:53

Вы хотите сделать пакет "держать"

https://help.ubuntu.com/community/PinningHowto#Introduction_to_Holding_Packages

В основном вы хотите сделать что-то вроде:

Эхо рнр5-общее владение | команды dpkg --сэт-выбор

И когда вы будете готовы обновить php:

Эхо рнр5-обычная установка | команды dpkg --сэт-выбор

Если вы хотите продолжать использовать обновления dotdeb, которые приходят в, и держаться подальше от пакетов Ubuntu, требуется полное закрепление apt, но это довольно сложно (см. PinningHowto связан выше).

+348
Roman Truba 21 апр. 2014 г., 3:10:52

Не могли бы вы сказать мне шаги, один за другим, чтобы добраться до него? Это немного сложно для меня сейчас.

+266
estobin 5 мая 2016 г., 15:41:45

В Убунту сенсорный простой пользовательский интерфейс применение шаблона поможет вам создать основу приложения, которое использует в Ubuntu SDK и имеет родной внешний вид Ubuntu и может интегрироваться с остальной частью платформы. Это рекомендуемый способ, чтобы начать писать свои первые приложения в Ubuntu, и вы будете использовать язык программирования с QML.

С помощью Qt GUI приложения, создадим простое приложение, используя Qt, но он не будет использовать Ubuntu в СДК (если вы вручную добавить его позже). Приложение будет основано на фундаменте Qt и с++. Это не рекомендуемый способ, чтобы начать работу, но приложение будет работать нормально в Ubuntu, хотя он может не иметь родной выглядеть и чувствовать себя из других приложений Убунту.

И да, в то время как мы рекомендуем и призываем версии Ubuntu SDK, в нашем сообществе будут рады практически любые приложения и вклада в Убунту! :)

+256
Miguel Hermoso 3 апр. 2018 г., 0:00:43

Если вам нужно использовать USB вместо внутреннего устройства, я предлагаю вам список драйвера для внутреннего устройства. Что позволит вам держать переключатель и использовать USB. Он имеет рабочий драйвер rtl8187 и создал интерфейс wlan1.

Узнайте драйвер для внутреннего с:

команда sudo lshw -C сетевой

Найти ту часть, которая относится к 'водитель=' связанных с как wlan0, внутренние. Затем черного списка это:

судо Су
Эхо "черного списка <some_driver>" > > в /etc/команды modprobe.д/игнор.конф
выход

Подключите USB, перезагрузитесь и оно должно работать. Если есть сомнения по поводу правильного водителя в черный список, размещайте свои выводы и мы поможем.

+247
Dan Shrubsole 5 февр. 2011 г., 2:24:45

Мне понравилось в Ubuntu 12.10, так я его скачал и и установил через WUBI, тогда он сказал мне, чтобы перезагрузить компьютер, чтобы завершить установку. После я перезагрузил и выбрал Ubuntu в операционной системы отбора; в течение нескольких секунд пустой экран пришел, а затем он показал тень пароль; затем пустой экран на несколько секунд; а потом много код-символы, как пришли, и он просто не загрузиться. Я просто хочу использовать 12.10 ничего не надо, у меня Виста бизнес, установленной на диске C:/, и Ubuntu установлена на F:/ диск (F:/ubuntu).

+238
emett 13 окт. 2013 г., 0:08:49

Показать вопросы с тегом